Skip to main content
Version: 9.x

Requirements

Requirements#

  • GIT
  • PHP >= 7.2 (7.4 is recommended)
  • PHP Extensions:
    • OpenSSL PHP Extension
    • PDO PHP Extension
    • Mbstring PHP Extension
    • Tokenizer PHP Extension
    • BCMath PHP Extension (required when the Hash ID feature is enabled)
    • Intl Extension (required when you use the Localization Container)
  • Composer
  • Node (required for the API Docs generator feature)
  • Web Server (example: Nginx)
  • Cache Engine (example: Redis)
  • Database Engine (example: MySQL)
  • Queues Engine (example: Beanstalkd)
Last updated on by Moslem Deris